Elite Dangerous System Requirements

Are you going to paly the Elite Dangerous, and looking for Elite Dangerous System Requirements. Finally, Here you can read both minimum and recommended which is provided by Can You RUN It.

Elite Dangerous-Icon
TITLE: Elite Dangerous
GENREAction, Adventure, Massively Multiplayer, RPG, Simulation, Strategy
DEVELOPERFrontier Developments
PUBLISHERFrontier Developments
RELEASE DATE: 2 Apr, 2015

Elite Dangerous System Requirements:

Windows
Mac OS X
SteamOS + Linux
    Minimum:
    • OS: Windows 7/8/10 64-bit
    • Processor: Quad Core CPU (4 x 2Ghz)
    • Memory: 6 GB RAM
    • Graphics: Nvidia GTX 470/AMD R7 240
    • DirectX: Version 11
    • Network: Broadband Internet connection
    • Storage: 25 GB available space
    Recommended:
    • OS: Windows 7/8/10 64-bit
    • Processor: Intel Core i7-3770K Quad Core CPU or better / AMD FX 4350 Quad Core CPU or better
    • Memory: 8 GB RAM
    • Graphics: Nvidia GTX 770 / AMD Radeon R9 280X
    • DirectX: Version 11
    • Network: Broadband Internet connection
    • Storage: 25 GB available space
    • Additional Notes: Supports SteamVR, Oculus Rift and TrackIR
Elite Dangerous Yet, not available for Mac OS X. Please check back again. We will update when it is available.
Elite Dangerous Yet, not available for SteamOS + Linux. Please check back again. We will update when it is available.

Elite Dangerous is available in the following languages:

Interface Full Audio Subtitles
English
French
German
Russian
Spanish – Spain
Portuguese – Brazil

You can also check Sid Meier’s Civilization® V System Requirements

Elite Dangerous System Requirements recommendation By Can You RUN It

If you want to run Elite Dangerous on PC/Laptop, then you must have a machine with following specification. You will need a machine at last have Windows 7/8/10 64-bit with 6 GB RAM, Quad Core CPU (4 x 2Ghz), You will need Nvidia GTX 470/AMD R7 240, and HDD 25 GB available space.

You may also like...

Leave a Reply

Your email address will not be published.