Kingdom Under Fire: The Crusaders System Requirements

Are you going to paly the Kingdom Under Fire- The Crusaders, and looking for Kingdom Under Fire- The Crusaders System Requirements. Finally, Here you can read both minimum and recommended which is provided by Can You RUN It.

Kingdom Under Fire- The Crusaders-Icon
TITLE: Kingdom Under Fire: The Crusaders
GENREAction, RPG, Strategy
DEVELOPERBlueside
PUBLISHERBlueside, BSV Holdings
RELEASE DATE: 28 Feb, 2020

Kingdom Under Fire- The Crusaders System Requirements:

Windows
Mac OS X
SteamOS + Linux
    Minimum:
    • OS: Windows 7 32bit
    • Processor: Intel Core 2 Duo or AMD Athlon 64×2 5600+
    • Memory: 4 GB RAM
    • Graphics: NVIDIA® GeForce® GT 420 or ATI™ Radeon™ HD 6850 or Intel® HD Graphics 4000 or better with 2 GB VRAM
    • DirectX: Version 9.0
    • Storage: 2 GB available space
Kingdom Under Fire- The Crusaders Yet, not available for Mac OS X. Please check back again. We will update when it is available.
Kingdom Under Fire- The Crusaders Yet, not available for SteamOS + Linux. Please check back again. We will update when it is available.

Kingdom Under Fire- The Crusaders is available in the following languages:

Interface Full Audio Subtitles
English
French
Italian
German
Japanese
Korean
Simplified Chinese

You can also check Frostpunk System Requirements

Kingdom Under Fire- The Crusaders System Requirements recommendation By Can You RUN It

If you want to run Kingdom Under Fire- The Crusaders on PC/Laptop, then you must have a machine with following specification. You will need a machine at last have Windows 7 32bit with 4 GB RAM, Intel Core 2 Duo or AMD Athlon 64×2 5600+, You will need NVIDIA® GeForce® GT 420 or ATI™ Radeon™ HD 6850 or Intel® HD Graphics 4000 or better with 2 GB VRAM, and HDD 2 GB available space.

You may also like...

Leave a Reply

Your email address will not be published.