Last Year System Requirements

Are you going to paly the Last Year, and looking for Last Year System Requirements. Finally, Here you can read both minimum and recommended which is provided by Can You RUN It.

Last Year-Icon
TITLE: Last Year
GENREAction
DEVELOPERElastic Games
PUBLISHERElastic Games
RELEASE DATE: 10 Dec, 2019

Last Year System Requirements:

Windows
Mac OS X
SteamOS + Linux
    Minimum:
    • Requires a 64-bit processor and operating system
    • OS: Windows 7 64 Bit or newer
    • Processor: Intel Core i3 4130T (2.9GHz) / AMD FX 6300 (3.5 GHz)
    • Memory: 8 GB RAM
    • Graphics: Nvidia GeForce GTX 470 (1 GB) / AMD Radeon HD 7770 (1 GB)
    • DirectX: Version 11
    • Network: Broadband Internet connection
    • Storage: 30 GB available space
    Recommended:
    • Requires a 64-bit processor and operating system
    • OS: Windows 7 64 Bit or newer
    • Processor: Intel i5 – 6600K (3.5 GHz) / AMD Ryzen 5 1600X (3.6 GHz)
    • Memory: 8 GB RAM
    • Graphics: Nvidia GeForce GTX 780 (3GB) / AMD Radeon 7870 (2GB)
    • DirectX: Version 11
    • Network: Broadband Internet connection
    • Storage: 30 GB available space
Last Year Yet, not available for Mac OS X. Please check back again. We will update when it is available.
Last Year Yet, not available for SteamOS + Linux. Please check back again. We will update when it is available.

Last Year is available in the following languages:

Interface Full Audio Subtitles
English

You can also check Wolcen- Lords of Mayhem System Requirements

Last Year System Requirements recommendation By Can You RUN It

If you want to run Last Year on PC/Laptop, then you must have a machine with following specification. You will need a machine at last have Windows 7 64 Bit or newer with 8 GB RAM, Intel Core i3 4130T (2.9GHz) / AMD FX 6300 (3.5 GHz), You will need Nvidia GeForce GTX 470 (1 GB) / AMD Radeon HD 7770 (1 GB), and HDD 30 GB available space.

You may also like...

Leave a Reply

Your email address will not be published.