LEGO® Worlds System Requirements

Are you going to paly the LEGO® Worlds, and looking for LEGO® Worlds System Requirements. Finally, Here you can read both minimum and recommended which is provided by Can my pc run it.

LEGO® Worlds-Icon
TITLE: LEGO® Worlds
GENREAdventure
DEVELOPERTT Games, Traveller’s Tales
PUBLISHERWarner Bros. Interactive Entertainment
RELEASE DATE: 7 Mar, 2017

LEGO® Worlds System Requirements:

Windows
Mac OS X
SteamOS + Linux
    Minimum:
    • OS: Windows 7
    • Processor: Intel Dual Core 2GHz
    • Memory: 4 GB RAM
    • Graphics: 512MB GPU with Shaders 3.0
    • DirectX: Version 9.0
    • Network: Broadband Internet connection
    • Storage: 10 GB available space
    Recommended:
    • OS: Windows 7
    • Processor: AMD or Intel Quad Core running at 2.6GHz
    • Memory: 4 GB RAM
    • Graphics: NVIDIA GeForce GTX 480 or ATI Radeon HD 5850 or better
    • DirectX: Version 11
    • Network: Broadband Internet connection
    • Storage: 10 GB available space
LEGO® Worlds Yet, not available for Mac OS X. Please check back again. We will update when it is available.
LEGO® Worlds Yet, not available for SteamOS + Linux. Please check back again. We will update when it is available.

LEGO® Worlds is available in the following languages:

Interface Full Audio Subtitles
English
French
German
Spanish – Spain
Danish
Russian
Italian
Japanese
Polish
Portuguese – Brazil
Simplified Chinese
Dutch
Traditional Chinese
Arabic
Czech
Hungarian
Korean
Portuguese
Swedish
Turkish

You can also check EARTH DEFENSE FORCE 5 System Requirements

LEGO® Worlds System Requirements recommendation By Can my pc run it

If you want to run LEGO® Worlds on PC/Laptop, then you must have a machine with following specification. You will need a machine at last have Windows 7 with 4 GB RAM, Intel Dual Core 2GHz, You will need 512MB GPU with Shaders 3.0, and HDD 10 GB available space.

You may also like...

Leave a Reply

Your email address will not be published.