Vampyr System Requirements

Are you going to paly the Vampyr, and looking for Vampyr System Requirements. Finally, Here you can read both minimum and recommended which is provided by Can my pc run it.

Vampyr-Icon
TITLE: Vampyr
GENREAction, RPG
DEVELOPERDONTNOD Entertainment
PUBLISHERFocus Home Interactive
RELEASE DATE: 5 Jun, 2018

Vampyr System Requirements:

Windows
Mac OS X
SteamOS + Linux
    Minimum:
    • Requires a 64-bit processor and operating system
    • OS: Windows 7/8/10 (64 bits)
    • Processor: Intel Core i3-2130 (3.4 GHz)/AMD FX-4100 (3.6 GHz)
    • Memory: 8 GB RAM
    • Graphics: 2 GB, GeForce GTX 1050 (Legacy GPU: GeForce GTX 660) / Radeon R7 370
    • Storage: 20 GB available space
    Recommended:
    • Requires a 64-bit processor and operating system
    • OS: Windows 7/8/10 (64 bits)
    • Processor: Intel Core i7-3930K (3.2 GHz)/AMD Ryzen 5 1600 (3.2 GHz)
    • Memory: 16 GB RAM
    • Graphics: 4 GB, GeForce GeForce GTX 970 / GTX 1060 / Radeon R9 390
    • Storage: 20 GB available space
Vampyr Yet, not available for Mac OS X. Please check back again. We will update when it is available.
Vampyr Yet, not available for SteamOS + Linux. Please check back again. We will update when it is available.

Vampyr is available in the following languages:

Interface Full Audio Subtitles
English
French
German
Spanish – Spain
Portuguese – Brazil
Russian
Polish
Italian
Simplified Chinese

You can also check DRAGON QUEST BUILDERS™ 2 System Requirements

Vampyr System Requirements recommendation By Can my pc run it

If you want to run Vampyr on PC/Laptop, then you must have a machine with following specification. You will need a machine at last have Windows 7/8/10 (64 bits) with 8 GB RAM, Intel Core i3-2130 (3.4 GHz)/AMD FX-4100 (3.6 GHz), You will need 2 GB, GeForce GTX 1050 (Legacy GPU: GeForce GTX 660) / Radeon R7 370, and HDD 20 GB available space.

You may also like...

Leave a Reply

Your email address will not be published.